Major service outage

Incident Report for Lokalise

Postmortem

On February 10, 2025, our service experienced a 16-minute outage followed by 39 minutes of degraded functionality due to an issue with a system configuration.

What happened?
While improving our disaster recovery process, a misconfiguration in the system was introduced unintentionally. Initially, this did not cause issues, but when we attempted to roll back the change, it led to unexpected complications. As a result, our service platform became temporarily unavailable, requiring the reconstruction of certain system components to restore full functionality.

Impact

  • 12:30 – 12:46 UTC: Service outage.
  • 12:46 – 13:25 UTC: Service degradation—APP and API were operational. Some services remained unavailable (OTA, Workflows, Connectors, Review Center).

What we are doing to prevent this in the future
We recognize the importance of this event, and we have taken steps to ensure it does not happen again. Our key actions include:

  • Improving validation and monitoring processes to identify configuration issues before deployment.
  • Enhancing our tools and automations for faster services restoration.
  • Implementing blue-green deployment techniques, or equivalent, for seamless system upgrades.

We sincerely apologize for the disruption this caused and appreciate your patience as we work to make our systems more resilient. If you have any questions, please reach out to support@lokalise.com.

Posted Feb 14, 2025 - 09:03 UTC

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 13:29 UTC

Update

We have applied the fix and monitoring for issues.
Posted Feb 10, 2025 - 13:20 UTC

Update

We are investigating the slowness of application and Lokalise OTA service unavailable.
Posted Feb 10, 2025 - 13:13 UTC

Update

We are investigating the slowness of application and Lokalise OTA service unavailable.
Posted Feb 10, 2025 - 13:04 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 10, 2025 - 12:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2025 - 12:50 UTC

Update

We are continuing to investigate this issue.
Posted Feb 10, 2025 - 12:40 UTC

Investigating

We are currently investigating this issue.
Posted Feb 10, 2025 - 12:38 UTC
This incident affected: Lokalise API, Lokalise App, and Lokalise OTA.