Lokalise’s API is unavailable
Incident Report for Lokalise
Postmortem

Our team has identified high RAM usage by snapshot creation process. It was impacting bulk actions successful completion. The issue was already known to the Engineering team who were developing a long-term solution.

As a short-term fix we decided to move forward with a workaround. On July 22nd, 2022 our team released an option for users to deactivate the snapshot creation for bulk actions. That helped to avoid the limitation and unblock few affected customers.

We then prioritized the long-term solution to reduce RAM consumption during snapshot creation. After doing a proper testing it was released on July 14th, 2022. Further performance monitoring showed the solution has helped to restore bulk actions and snapshot functionality in full.

Please note that now snapshot creation takes more time for bigger projects with millions of entities like keys, translation history, etc. We had to find a better balance for RAM vs. time usage to make snapshot creation more stable and scalable.

Posted Aug 02, 2022 - 15:37 CEST

Resolved
Earlier today we experienced a MySQL database connection issue that made the application and API inaccessible. It was caused by data migration in one of the releases. We successfully rolled back and restored full functionality. We appreciate your understanding and are sorry for the inconvenience.
Posted Jun 22, 2022 - 14:00 CEST