Lokalise APP performance degradation

Incident Report for Lokalise

Postmortem

On February 19, 2025, our service experienced performance degradation in background tasks that impacted essential processes including file imports, synchronization with content integrations, and some bulk actions.

What happened?
A faulty release unintentionally caused our background tasks to stop working as expected. Although the issue did not appear immediately, it became noticeable the next morning. Our team promptly investigated and mitigated the problem, quickly restoring full service.

Impact

  • 08:54 UTC to 09:23 UTC: Customers experienced slower performance.

What we are doing to prevent this in the future
We recognize the importance of this event, and we are taking steps to ensure it does not happen again. Our key actions include:

  • Additional monitoring of background tasks to quickly spot issues
  • Exploring options for our system to recover automatically from minor errors.

We sincerely apologize for the inconvenience this incident caused. Thank you for your patience and understanding as we continue to improve Lokalise’s resilience and reliability. If you have any questions or require further assistance, please contact hello@lokalise.com.

Posted Feb 27, 2025 - 12:49 UTC

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 10:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2025 - 10:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 19, 2025 - 10:16 UTC

Update

We have restored the functionality to unblock customers. We are continuing to investigate the root cause.
Posted Feb 19, 2025 - 09:22 UTC

Update

All functionality that is relying on background processes is affected. We are continuing to investigate this issue.
Posted Feb 19, 2025 - 09:13 UTC

Investigating

Some actions like file import, bulk actions are not being processed. We are investigating this issue.
Posted Feb 19, 2025 - 08:58 UTC
This incident affected: Lokalise App.